Android Emulator with Ubuntu 12.10

The Emulator of Android SDK expects 32bit GL graphics drivers and does not work out of the box with the 64bit GL libraries being installed by default with Ubuntu 12.10. You will get something like the following error message “libGL error: failed to load driver: i965”. You can solve the dependency installing the 32bit libraries (i386) manually the following way:

sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

Leave a Reply

Your email address will not be published. Required fields are marked *